Thread: Be mindful of lens mount contacts

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22
  1. #11  
    Senior Member Thekreative's Avatar
    Join Date
    Apr 2012
    Location
    SaltSpring Island BC CANADA
    Posts
    275
    Quote Originally Posted by Kholi View Post
    And I can't do a backflip, it ends up turning into a sideflop; not elegant at all.
    Awesome Kholi!
    Reply With Quote  
     

  2. #12  
    Moderator
    Join Date
    Apr 2012
    Posts
    4,333
    That was my single tantrum for the rest of the year. xD But if you do cut the nose off of the camera make sure you take pictures of the process.

    SKYPE (best way to talk to me): Camera_Kholi | twitter
    Avery and Pete: Superseeds Feature Film Trailer
    Reply With Quote  
     

  3. #13  
    Senior Member Thekreative's Avatar
    Join Date
    Apr 2012
    Location
    SaltSpring Island BC CANADA
    Posts
    275
    The more scotch I drink the more I get tempted to grab my tool kit and void the warranty.
    The isn't much in there.... you can see a lot of it from inside the ssd port.
    I bet it comes apart in seconds...... where is engadget to sponsor this video?
    Reply With Quote  
     

  4. #14  
    Senior Member Thekreative's Avatar
    Join Date
    Apr 2012
    Location
    SaltSpring Island BC CANADA
    Posts
    275
    Just got a note from Kristian at BM on there forum:

    Hi,

    While the damage won't be covered under warranty, it's not going to cost a lot to fix. Once you have the downtime and want to get it sorted, contact tech support and speak to Kaspar. He'll sort you out.

    You should only have to pay for shipping to and from our Fremont office in the US which won't be much.


    Makes me glad we have forums after what I was first told!
    Reply With Quote  
     

  5. #15  
    Senior Member Thekreative's Avatar
    Join Date
    Apr 2012
    Location
    SaltSpring Island BC CANADA
    Posts
    275
    Some one on the BM forum suggested that it might be from a "chipped" adapter and I'm sure that is what has caused it. Time to get the chip off of them.
    Last edited by Thekreative; 02-27-2013 at 03:21 PM.
    Reply With Quote  
     

  6. #16  
    Senior Member
    Join Date
    Jul 2012
    Posts
    827
    Double check it to be sure that it is not your lenses, for example I checked my old manual Nikon lenses and I found out that some of the metal parts on the back of the lens comes very close to the chip contacts.
    Non of my passive Nikon to EOS mount adapters have anything sticks out close to the chip contacts.
    Reply With Quote  
     

  7. #17  
    Chop the chips !
    Reply With Quote  
     

  8. #18  
    Senior Member teh's Avatar
    Join Date
    Sep 2012
    Posts
    462
    what kind of adapters did you use? makes me worried.
    Reply With Quote  
     

  9. #19  
    Senior Member Thekreative's Avatar
    Join Date
    Apr 2012
    Location
    SaltSpring Island BC CANADA
    Posts
    275
    I've got lots but the ones with af confirm have to go. The BMC doesn't use it so get adapters without or take them off!
    Reply With Quote  
     

  10. #20  
    Taking a Vacation
    Join Date
    Sep 2013
    Posts
    383
    So what happened then Kholi??? Care to share??
    Reply With Quote  
     

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •