Thread: Sigma 70-200mm f/2.8 EX DG APO OS HSM

Results 1 to 6 of 6
  1. #1 Sigma 70-200mm f/2.8 EX DG APO OS HSM 
    Senior Member
    Join Date
    Jul 2012
    Posts
    109
    Anyone looking at this lens?

    Not sure how much I'd use it.

    I'm seeing it's discounted $250 but I think that deal ends midnight tonight (who knows, maybe there's an ART version in the wings?).
    Ursa Mini Pro, Tokina 11-20, Sigma 18-35, Rokinon 35, 50, 85, 135, GH4, Lumix 20, 12-35, 35-100, 100-300.
    Reply With Quote  
     

  2. #2  
    Quote Originally Posted by dregenthal View Post
    Anyone looking at this lens?

    Not sure how much I'd use it.

    I'm seeing it's discounted $250 but I think that deal ends midnight tonight (who knows, maybe there's an ART version in the wings?).
    Just got mine from eBay. The auto focus works but the iris is not current communicating with the mini 4.6k at the current moment.
    Reply With Quote  
     

  3. #3  
    Quote Originally Posted by parkerj View Post
    Just got mine from eBay. The auto focus works but the iris is not current communicating with the mini 4.6k at the current moment.
    I didnt read the description before I bought it. Apparently this is what the lens is stuck on due to old electronics that communicates to the camera. I'm an idiot, should have read it before I purchased. But even at wide open it's a beautiful fit with the mini.
    Reply With Quote  
     

  4. #4  
    Junior Member
    Join Date
    Dec 2016
    Posts
    13
    Quote Originally Posted by parkerj View Post
    I didnt read the description before I bought it. Apparently this is what the lens is stuck on due to old electronics that communicates to the camera. I'm an idiot, should have read it before I purchased. But even at wide open it's a beautiful fit with the mini.
    Hello PARKERJ , I am a french guy owning a MINI 4.6 .. Several months ago , I had the same problem with a Sigma 18-35 I bought maybe two years ago , so a bit old .. The Iris did not work , sometimes there was a Value displayed , most often Nothing .. I solved the problem with a " SIGMA USB DOCK " , a not very expensive accessory .. You have to download a small application from Sigma , you mount your lens on the Dock , USB connected on your computer , the Sigma servers are going to identify your lens and check whether there is a firmware update available .. If so , then you can update .. IT WORKED FOR ME . The problem is coming of a bad dialog between the Camera's firmware and the lens firmware . Also , note that TWO VERSIONS of the USB DOCK exist : one for Nikon mount lenses and one for Canon mounts .. so make no mistake . Of course , there never is a total guarantee .. but I am sure it might work .. That is also a guarantee you always have the latest firmware for your Sigma lenses ..

    Happy to help , I hope your problem will be solved .

    And also , a Happy new year 2017 , do your best to keep a good health and a good mind ..

    My Best Regards from France / Michel ...
    Reply With Quote  
     

  5. #5  
    Quote Originally Posted by Michel59 View Post
    Hello PARKERJ , I am a french guy owning a MINI 4.6 .. Several months ago , I had the same problem with a Sigma 18-35 I bought maybe two years ago , so a bit old .. The Iris did not work , sometimes there was a Value displayed , most often Nothing .. I solved the problem with a " SIGMA USB DOCK " , a not very expensive accessory .. You have to download a small application from Sigma , you mount your lens on the Dock , USB connected on your computer , the Sigma servers are going to identify your lens and check whether there is a firmware update available .. If so , then you can update .. IT WORKED FOR ME . The problem is coming of a bad dialog between the Camera's firmware and the lens firmware . Also , note that TWO VERSIONS of the USB DOCK exist : one for Nikon mount lenses and one for Canon mounts .. so make no mistake . Of course , there never is a total guarantee .. but I am sure it might work .. That is also a guarantee you always have the latest firmware for your Sigma lenses ..

    Happy to help , I hope your problem will be solved .

    And also , a Happy new year 2017 , do your best to keep a good health and a good mind ..

    My Best Regards from France / Michel ...

    Thanks Man!

    I do have the dock, and unfortunately even the sigma dock doesn't communicate or recognize the lens. I'm going to send it in to Sigma, and let them replace the electronics in it. I think that's the solution.
    Reply With Quote  
     

  6. #6 Sigma 70 -200 
    Junior Member
    Join Date
    Dec 2016
    Posts
    13
    Quote Originally Posted by parkerj View Post
    Thanks Man!

    I do have the dock, and unfortunately even the sigma dock doesn't communicate or recognize the lens. I'm going to send it in to Sigma, and let them replace the electronics in it. I think that's the solution.
    OK PARKERJ , well , if you are sure your Dock is OK , then .. just have a look to the quality of the contacts ... if you own a Canon Dslr .. or if someone around you owns one .. you can try the lens on it ... but ok , if the electronics is dead , there is no other solution .. so back to Sigma ..

    Anyway , happy to help , and All the Best from Northern France / Michel
    Reply With Quote  
     

Similar Threads

  1. Nikon 70-200mm f/2.8 AF-S VR
    By Grug in forum For Sale / Want to Buy
    Replies: 0
    Last Post: 10-03-2015, 10:03 PM
  2. Canon 70-200mm F/4L IS USM
    By weis5on in forum For Sale / Want to Buy
    Replies: 1
    Last Post: 09-14-2015, 05:38 PM
  3. Replies: 9
    Last Post: 09-16-2014, 04:35 PM
  4. Sigma 70-200mm F2.8 on BMPCC EF Speedbooster?
    By Connor_R in forum Lens Discussion
    Replies: 0
    Last Post: 09-12-2014, 05:23 PM
  5. FS: Canon EF 70-200mm f 2.8 L USM
    By Taj Jackson in forum For Sale / Want to Buy
    Replies: 0
    Last Post: 12-22-2013, 06:43 PM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •